Gimp.org

Le suivi du développement

Futur et développement de Gimp

Le futur de Gimp est périodiquement évoqué lors de rencontres informelles appelées « Gimpcon ». Depuis 2007, les « Gimpcon » sont intégrés dans un rassemblement plus vaste autour des logiciels libres d'infographie appellé « LGM » pour Libre Graphics Meeting. Mais dans le monde du logiciel libre tout n'est jamais respecté à la lettre et des fonctionnalités peuvent finalement apparaitre bien plus tard qu'envisagé au départ ou au contraire bien plus tôt. Il est également possible de faire un suivi très rapproché en consultant des fichiers regroupants l'ensemble des modifications apportées au code source de l'application. Dans les menus de droite vous trouverez quelques liens à suivre pour de plus amples renseignements.

Les derniers LGM 2021 ont eu lieu à Rennes en mai 2021.

Suivi du développement

GIMP 2.99.4 et 2.99.6: don't worry, be h-API!.

Development release GIMP 2.99.4 is out.

25 ans de GIMP et version de développement 2.99.2 : premiers pas vers GIMP 3 !. La version officielle en anglais est sur Development release GIMP 2.99.2 is out.

Gimp 2.10 roule au gegl (ou Nouveautés de la version 2.10) récapitule ce qui est sorti avec Gimp-2.10. La version officielle en anglais est sur GIMP 2.10 Release Notes.

Chaque fin d'année les développeurs de Gimp diffusent un résumé des travaux réalisés pendant l'année. Voici le Gimp and Gegl en 2019.

Gimpfr ne fait pas de suivi précis du développement faute de contributeur pour développer cette rubrique.

Tester

Des paquets Flatpak pour Linux sont disponibles.

Des exécutables Windows sont automatique générés chaque nuit.

Il est possible de tester les versions de développement sous Linux à partir du code source. Attention les versions de développement ne cohabitent pas avec les versions stables de Gimp.

Des paquets Mac, Linux ou des binaires Windows sont parfois distribués par des personnes tierces. La distribution de ces versions de développement est astreinte au devoir d'informer les utilisateurs qu'il s'agit de versions de développement instables, incomplètes, non documentés et peut-être incompatibles aves les greffons et scripts existants. Ceci est malheureusement souvent omis délibérement ou négligemment.